• На форуме сменился адрес почты, с которой вам приходят уведомления. Теперь этот адрес такой: noreply@dayzrussia.com
    Если вам не приходят уведомления с нашего форума, то добавьте этот адрес в свою адресную книгу и проверьте спам. На этот адрес письма не принимаются, они останутся без ответа.
  • Форум обновлен в экспериментальном режиме. Обо всех замеченных проблемах сообщать в эту тему

Обновление форума и вики

-=PA=-Михаил

руководитель DayZ Russia
Команда форума
UPD:
Список предложений и замечаний

Раньше можно было навести курсор на ник, и выплывало окошко, с действиями. Теперь только, когда нажмешь. Я не жалуюсь, но удобнее, когда оно само вылезает



_

Друзья.

Наша материально-техническая база безнадежно устарела. Мы сейчас работаем на форуме и wiki образца 2014 года. Можно продолжать в том же духе, это не катастрофа. Есть риск всяких уязвимостей, но мы не Сбербанк и никому в сущности нафиг не сдались нас хакать или ддосить. Есть проблема нагрузки, то есть производительности. PHP7 чуть ли не на 50% быстрее, ну там, надежнее опять же, мног окрутого на нем делается и нового.

И всё бы ничего, но движок вики точно нужно обновить, а он зараза уже всё, только PHP7. Сделать в одном пространстве и 7 и 5 версию не получится, только какая-то одна. Если обновить до 7, то нужно и форум заменить. В сущности, момент крайне удачный, чтобы начать всё с чистого листа. Вполне возможно, что многие плюшки форума удастся сохранить или портировать. При обновлении мы выигрываем, но оно может означать, что некоторые материалы или функционал могут потеряться.

Мда... Я пошел еще поискал что потянется следом... ту и базу данных нужно обновлять.

Так что решение точно у нас только одно. Завести отдельный сервак, поставить туда все новое, обкатать, проверить совместимость, настроить, перенести все, что можно, ну то есть сохранить максимум контента форума. Тогда мы убедимся, что у нас ничего не сломалось и обновлять всю платформу...

И еще беда в том, что у меня на этом сервер крутится еще два других важных проекта, которые еще отдельно тестить... Ох.

Есть риск, что для полноценной работы нужно будет выносить полностью на собственный хостинг всё новое.

И уже начинаю думать, что не потяну я такое, придется терпеть старье.

И еще последний промежуточный вариант - найти не последнюю вики, а последнююю, которая подходит под наши техтребования.

У кого какие мысли?
 
Последнее редактирование:

-=PA=-Михаил

руководитель DayZ Russia
Команда форума
У нас
  • Mediawiki 1.26.0 (2014)
  • PHP 5.6.30
  • MySQL 5.5.48
MediaWiki 1.31 (September 2017)
  • PHP 7.0.0
  • MySQL 5.5.8 or later
MediaWiki 1.30 (9 May 2017)
  • PHP 5.5.9 or later.
  • MySQL 5.5.8 or later
Запустил скрипт совместимости нового движка Xenforo 2. Он говорит всё ок, не надо 7.0.0 и база его наша устраивает. Красота. Но без нового движка форума мы еще протянем, хотя иногда сильно тормозит.

Сейчас спрошу у провайдера, можно ли докрутить наш хостинг на SQL 5.5.8 соответственно. Есть подозрение, что в пределах третьей цифры не будет проблем.
 
Последнее редактирование:

-=PA=-Михаил

руководитель DayZ Russia
Команда форума
Здравствуйте!

Спасибо за обращение.
Вы используете услугу shared-хостинга, т.е. общее программное обеспечение с другими клиентами, поэтому мы не можем по запросу менять глобальные настройки хостинга.
Планов по обновлению версии MySQL в рамках используемого вами хостинга на ближайшее время нет.
При этом в рамках нового хостинга https://infobox.ru/hosting/ используется MariaDB 5.5.52. Если вам подходит данная версия, то вы можете перейти на новый хостинг.
Также вы можете заказать услугу виртуального сервера https://infobox.ru/vps/ и установить на него любое необходимое вам ПО.
Все вопросы отпали. Поэтому я сейчас поставлю все новые движки параллельно и просто подберем ту версию, которая заработает.
 

-=PA=-Михаил

руководитель DayZ Russia
Команда форума
Есть тут шарящие люди? Или кто может помочь разобраться?
MediaWiki 1.30 не запускается
MediaWiki 1.30 internal error
Installing some external dependencies (e.g. via composer) is required.

External dependencies
MediaWiki now also has some external dependencies that need to be installed via composer or from a separate git repo. Please see mediawiki.org for help on installing the required components.
Это какой-то бред, потому что даже не пишет, какие именно зависимости нужны, в доках вобоще нет такого. Инсталляшка из коробки сразу.

Вот качал отсюда. https://tools.wmflabs.org/snapshots/#!/mediawiki-core/REL1_30
Пробовал и на серваке распаковывать и локально и заливать отдельно пофайлово.

Кто может где-нить установить? Может я туплю?
 

MYesutin

Доброволец DZR|D
Whitelist DZR
Есть тут шарящие люди? Или кто может помочь разобраться?
MediaWiki 1.30 не запускается


Это какой-то бред, потому что даже не пишет, какие именно зависимости нужны, в доках вобоще нет такого. Инсталляшка из коробки сразу.

Вот качал отсюда. https://tools.wmflabs.org/snapshots/#!/mediawiki-core/REL1_30
Пробовал и на серваке распаковывать и локально и заливать отдельно пофайлово.

Кто может где-нить установить? Может я туплю?
Я могу у себя на сервере попробовать, конечно. Если пара часов ничего не решает.
Но по идее в инструкции должно было быть написано как композером обновлять.
 

-=PA=-Михаил

руководитель DayZ Russia
Команда форума
Я могу у себя на сервере попробовать, конечно. Если пара часов ничего не решает.
Но по идее в инструкции должно было быть написано как композером обновлять.
Очень прошу, попробуй. Не решат ни два часа, ни два дня :) Я один, любая помощь = супер скорость. Я через час уже уеду в светлую пятницу, потом буду только завтра у компа.

Мне вот предложили запустить composer install в папке с проектом. Только вики всегда был обычной веб фигней. Я прошлый раз скачал, распаковал, index.php и там все само промолотило, я только вводил базы, пароли, аккаунты и всё заработало.

Здесь какой-то баг или шайтан. А может и правда уже на композере все, тогда хз. В доках нет ничего такого, а может я с недосыпу не вижу.
 

-=PA=-Михаил

руководитель DayZ Russia
Команда форума
Использование в Медиавики
Медиавики 1.25+ зависит от некоторых внешних библиотек, которые управляются с помощью Composer. Composer создаёт автозагрузчик на vendor/autoload.php, который включен в WebStart.php.

Composer управляет зависимостями, сгруппированными в архив дистрибутива MediaWiki и расширений, так что системным администраторам не нужно непосредственно использовать composer.
:confused:
 

MYesutin

Доброволец DZR|D
Whitelist DZR
Последнее редактирование:

-=PA=-Михаил

руководитель DayZ Russia
Команда форума
Вот скотина, чего же ему у меня не хватило. Выложи плиз. Очень буду благодарен, @MYesutin
 

-=PA=-Михаил

руководитель DayZ Russia
Команда форума
Форум обновлен. Делимся предложениями и замечаниями.
 

Riddick

Посвященный
Скажу честно - работает быстрее, но теперь это похоже на вконтакт. Всё белёсое, нет чередующихся цветов, глазу не за что уцепится, да ещё и аватарки стали круглыми - пол головы теперь отрезано. Функционал теперь навсегда английский? Или планируется перевод? А то рядом висят "хоме", "форумс", "ватс нью", и "поиск", но уже по-русски. Это не придирки, я просто перфекционист, наверное.
 

-=PA=-Михаил

руководитель DayZ Russia
Команда форума
Всё белёсое, нет чередующихся цветов, глазу не за что уцепится
Тему настроим как нам захочется. Как минимум, настроим её не хуже, чем было.
аватарки стали круглыми
Исследую, как сделать обычные.
Функционал теперь навсегда английский?
Нет, файл перевода просто загрузить надо :) сейчас закину.
Это не придирки, я просто перфекционист, наверное.
Прекрасные придирки. Продолжайте. Нам здесь должно быть комфортно как дома, как было раньше :)
 

Riddick

Посвященный
Спасибо! Нет, правда - спасибо! Я только надеюсь, что это не только мне так нравится, а другие ребята скажут, как лучше всем, а не только мне. М-м-м, можно добавки? Нехватает пометки, около аватарки, или никнэйма, что пользователь он-лайн. Спасибо, ещё раз.
 

-=PA=-Михаил

руководитель DayZ Russia
Команда форума

-=PA=-Михаил

руководитель DayZ Russia
Команда форума
Вы еще с телефона посмотрите. Тут роскошная мобильная тема. Я когда её увидел точно решил, хочу и всё.
 

-=PA=-Михаил

руководитель DayZ Russia
Команда форума
Осталось настроить цветовые схемы и накатить всякие плагины. Вот скрин плагинов с тестовой сборки. Авторизация через стим только пока не работает.
794
 

kraft

Специалист
Whitelist DZR
Михаил, превосходная работа, все круто, стильно, быстро! Спасибо за труд!

p.s. на главной форума на моем мониторе некорректно отображаются шрифты, как я понимаю, дело в верстке.
795
\\by kraft
 

Riddick

Посвященный
Ещё раз спасибо, Михаил! Вот Вас-бы на разработку DayZ.. отдельное спасибо за аватарки. Раньше можно было навести курсор на ник, и выплывало окошко, с действиями. Теперь только, когда нажмешь. Я не жалуюсь, но удобнее, когда оно само вылезает. Ребзя, если Вам удобнее по другому, напишите, что-бы Михаил два раза не переделывал!

А с телефона вряд-ли получится, ну если только под старые нокии заточено. У меня н5800хм. Я был, в своё время, на волне, да. Теперь я понял, зачем нужны новинки, и не гонюсь. Звонить мне и моей хватает.
 
Последнее редактирование:

-=PA=-Михаил

руководитель DayZ Russia
Команда форума
Михаил, превосходная работа, все круто, стильно, быстро! Спасибо за труд!

p.s. на главной форума на моем мониторе некорректно отображаются шрифты, как я понимаю, дело в верстке.
Посмотреть вложение 795
\\by kraft
На тестовой сборке все ок, а тут после апгрейда ширина p-body-content слетает с 920 до 580. Это какие-то мои древние правки шаблонов, когда настраивал виджеты. Но я час искал, безуспешно. По стилям в админке многое поменялось. Буду копать дальше.
 
Сверху